rubygem-prawn

A fast and nimble PDF generator for Ruby


Up to date: No

Gitweb repository: http://pkgs.fedoraproject.org/cgit/rubygem-prawn.git

SPEC file: http://pkgs.fedoraproject.org/cgit/rubygem-prawn.git/tree/rubygem-prawn.spec

Upstream url: http://prawn.majesticseacreature.com

Maintainer: jstribny

Git Commits: 9

Last packager: Josef Stribny

Last commit message: Update to 2.0.2

Last commit date: August 24, 2015 12:00

Description: Prawn is a pure Ruby PDF generation library that provides a lot of great functionality while trying to remain simple and reasonably performant. Here are some of the important features we provide: - Vector drawing support, including lines, polygons, curves, ellipses, etc. - Extensive text rendering support, including flowing text and limited inline formatting options. - Support for both PDF builtin fonts as well as embedded TrueType fonts - A variety of low level tools for basic layout needs, including a simple grid system - PNG and JPG image embedding, with flexible scaling options - Reporting tools for rendering complex data tables, with pagination support - Security features including encryption and password protection - Tools for rendering repeatable content (i.e headers, footers, and page numbers) - Comprehensive internationalization features, including full support for UTF-8 based fonts, right-to-left text rendering, fallback font support, and extension points for customizable text wrapping. - Support for PDF outlines for document navigation - Low level PDF features, allowing users to create custom extensions by dropping down all the way to the PDF object tree layer. (Mostly useful to those with knowledge of the PDF specification) - Lots of other stuff!

Rawhide Fedora 27 Fedora 26 Gem Version
2.0.2 2.1.0

Dependency Tree

Dependencies: 6

Package Environment Rawhide f27 f26 Upstream
rubygem-pdf-core development 0.6.0 0.6.1
rubygem-pdf-inspector development 1.2.0 1.2.1
rubygem-pdf-reader development 1.3.3 1.4.0
rubygem-mocha development 1.1.0 1.1.0
rubygem-ttfunk development 1.4.0 1.4.0
rubygem-rspec development 3.4.0 3.4.0

Dependents: 1

Package Rawhide f27 f26 Upstream
rubygem-tilt 2.0.4 2.0.5
ID Title
1313335 rubygem-prawn-2.1.0 is available
Build ID Title
679458 rubygem-prawn-2.0.2-1.fc24
664318 rubygem-prawn-2.0.1-1.fc23
661102 rubygem-prawn-1.2.1-1.fc23